
July 2013

UTStudio

User Manual



Copyright © 2013

UTStudio - User Manualii

Table of Contents

11 Introduction

............................................................................................................................ 11.1 Overview

............................................................................................................................ 31.2 Supported Files

............................................................................................................................ 31.3 User Preferences

42 Starting an Analysis

73 Inspection Parameters

............................................................................................................................ 73.1 Views

......................................................................................................................................................... 73.1.1 Summary

......................................................................................................................................................... 93.1.2 Measurement

......................................................................................................................................................... 93.1.3 3D views

......................................................................................................................................................... 123.1.4 A-Scan

......................................................................................................................................................... 123.1.5 B/D-Scan

......................................................................................................................................................... 133.1.6 C-Scan

......................................................................................................................................................... 143.1.7 S-Scan

......................................................................................................................................................... 153.1.8 L-Scan

......................................................................................................................................................... 163.1.9 TOFD

......................................................................................................................................................... 163.1.10 Top and End

............................................................................................................................ 183.2 Inspection

............................................................................................................................ 193.3 Part

............................................................................................................................ 193.4 Probe

............................................................................................................................ 203.5 Wedge

............................................................................................................................ 203.6 Scan

............................................................................................................................ 223.7 Geometry

............................................................................................................................ 233.8 Encoder

............................................................................................................................ 243.9 Measurements

264 Analyzing Inspection Data

............................................................................................................................ 264.1 Customizing Layouts

......................................................................................................................................................... 274.1.1 Adding and Removing Views

......................................................................................................................................................... 294.1.2 Swapping Views

......................................................................................................................................................... 304.1.3 Rotating a View

......................................................................................................................................................... 314.1.4 Using the Zoom

......................................................................................................................................................... 324.1.5 Using Color Palettes

......................................................................................................................................................... 344.1.6 Extracting a View

......................................................................................................................................................... 364.1.7 Adding Sheets

............................................................................................................................ 374.2 Using Cursors and Gates

......................................................................................................................................................... 384.2.1 Adding and Deleting Cursors or Gates

......................................................................................................................................................... 384.2.2 Linking Cursors

......................................................................................................................................................... 404.2.3 Making Measurements w ith Gates

......................................................................................................................................................... 424.2.4 Preparing TOFD Data for Analysis



iiiTable of Contents

Copyright © 2013

............................................................................................................................ 474.3 Software Gain

............................................................................................................................ 484.4 Using the Part Overlay

............................................................................................................................ 494.5 Changing View and Cursor Properties

......................................................................................................................................................... 504.5.1 Changing the View Orientation

......................................................................................................................................................... 504.5.2 Changing Palette Color, Position, and Amplitude

......................................................................................................................................................... 514.5.3 Displaying Rulers and Grids

......................................................................................................................................................... 544.5.4 Using Overlay Parameters

......................................................................................................................................................... 544.5.5 Displaying Measurements in the View

......................................................................................................................................................... 564.5.6 Changing the Extracted View Display

......................................................................................................................................................... 564.5.7 Changing the 3D View Display

......................................................................................................................................................... 584.5.8 Annotation Table

625 Analyzing Multiple Files

636 Creating Reports

657 Exporting Thickness Tables as a CSV File

668 Creating Configuration Files for an Instrument

739 Help and Support



1

Copyright © 2013

UTStudio - User Manual

1 Introduction

This manual provides information for the UTStudio analysis software. It has been designed so that people with
good knowledge of ultrasonic testing can easily use the software to help them assess inspection data, make reports,
and create configurations to be used with Sonatest inspection instruments.

Note: Procedures presented in this document use commands from menus to explain how to
perform tasks; however, most of these same commands are available on the toolbar and in
contextual menus when you right-click  in a view.

1.1 Overview

This section presents the main components of UTStudio.

UTStudio main window

Menu bar

The menu bar provides access to all software functions such as opening files, interacting with the application,
and displaying help documentation.
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Toolbar

The toolbar provides quick access to software functions commonly used. These same functions are available
through the menus. Different buttons are available depending on the type of view selected.

1 New file 11 Properties 21 Zoom in

2 Open file 12 Annotations 22 Zoom out

3 Save file 13 Help 23 Rotate

4 Create report 14 3D options 24 Add cursor

5 Toggle units (mm/in.) 15 Rulers 25 Delete cursor

6 Toggle background 16 Palette position 26 Link cursor

7 Color palette editor 17 Palette selection 27 Unlink cursor

8 Add horizontal splitter 18 Depth/Amplitude 28 Add annotation

9 Add vertical splitter 19 Measure 29  Delete annotation

10 Delete area 20 Overlay

Tree

The Tree is one of the most important component of UTStudio. The Tree provides access to inspection data,
hardware settings, and views. The available information depends on the inspection settings. Some parameters
can be modified to help with the analysis. Each item from the Views tab can be dragged and dropped in an
empty view pane.

This is a dockable window that can be floated anywhere on screen or, if you use two monitors, you can move
the Tree on one monitor and UTStudio on the other. Once floated, the Tree window can be resized.

View pane

The view panes allow you to display a variety of information, such as summary of inspection information,
inspection data, part geometry, and probe position on the part, provided that all these parameters were
configured properly in the inspection configuration. You can also create a list of measurements that are of
particular interest. All these elements can be dragged and dropped from the Views and Measurements tabs of
the Tree directly in an empty pane.

The slider at the bottom of some views allows you to move through the inspection. You can move the slider
manually or use the arrows on the left to see the inspection frame by frame. You can also click the play button
to continuously play the inspection recording.
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1.2 Supported Files

This section presents the file types supported by UTStudio.

Two types of Sonatest files are supported: configuration (*.utcfg) and data (*.utdata).

Configuration

The configuration files contain all the information defining the probe, the wedge, the part geometry, and the
specific ultrasonic settings.

Data

The data files contain all the data collected during an inspection including the inspection configuration and the
acquisition layout.

1.3 User Preferences

Preferences for the interface, color palettes, and annotations are set in the Preferences dialog box. These will be the
default settings that will apply when starting UTStudio. To open the Preferences dialog box, on the Edit menu,
click Preferences.

    

The Preferences dialog box
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2 Starting an Analysis

Data analysis starts by opening a data file (*.utdata) generated by a Sonatest instrument. For the purpose of this
presentation, we are using example data files provided when installing UTStudio.

To open an analysis session:

1.  Start UTStudio.

2. On the File menu, click Open File.

File examples are stored in My Documents> My UTStudio Files> Examples.

The File menu
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3.  In the Open File dialog box, in the File name list, select a data file and click Open.

The Tree appears on the left-hand side of the main window.

Main window with the Tree

4. In the Tree area, click the Acquisition Layout and drag it to the view pane.

Dragging an inspection layout to the view pane

The layout used during acquisition is displayed.
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The acquisition layout

After you have worked on a data file, you can save your work by saving the .utdata file. If you do not want to
alter the original data, on the File menu, click Save As and, in the Save File dialog box, in the File name box, type
the name of the new file; otherwise, click the Save File command.
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3 Inspection Parameters

Inspection parameters are found in the Tree which opens at the left of the UTStudio main window when you open a
file (*.utdata or *.utcfg). The Tree includes information about the views, the inspection, the probes and wedges, the
part, and the scan.

3.1 Views

At the top of the Tree you have the Views tab. Each element can be dragged and dropped to an empty view. You
find a summary of inspection information, scan plans, and a variety of layouts whether user defined or standard. The
suggested content is customized for each data file and, therefore, will vary according to the inspection.

Elements available on the Views tab

3.1.1 Summary

The summary contains a choice of inspection information such as the inspection date, encoder type, probe and
wedge types, and notes. Yellow messages indicate elements that you should consider and red messages indicate
errors in the configuration.

The information can be copied in order to be pasted in another format; make a right-click in the view and, in the
contextual menu, click Select All and then Copy.
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Summary view
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3.1.2 Measurement

Measurement is an empty view that is used to drag and drop a selection of measurements from the Measurements
tab of the Tree (refer to Measurements).

   

The empty Measurements view (left), one measurement added in the view (right)

3.1.3 3D views

The 3D view allows you to see the scan plan of the part with its probes and wedges, provided these parameters
have been clearly defined before the inspection. The figure below presents an overall view but you can also view
separate elements by clicking and dragging specific probes (P1, P2, P3, etc.) or Scans (S1, S2, S3, etc.) in a view pane.

3D overall scan plan

As required by many codes, the position of the probe relative to the weld needs to be known and recorded. The
legend box in the top-right corner of the view presents the elements of the scan plan. Depending on the scan plans,
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different elements will appear in the legend.

The scan plan legend

The Part Datum, identified by a yellow dot, is an arbitrary point on the part under test. All ultrasonic data is
referenced to the part datum or the wedge reference.

The wedge reference (Wedge Ref), identified by a red dot, is different for each type of wedge or probe:
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Probe Type Reference Drawing

Phased array UT
Probe without wedge Reference point on the

center of the probe active
surface

Probe with a flat wedge Reference point on the
center of the wedge contact
surface

Probe with an angular
wedge

Reference point on the
center of the wedge front
edge

Conventional UT
Probe with or without
wedge

Reference point on the beam
exit point

In a multi-probe scenario, the probes and wedges are defined relative to a group reference (scanner) identified by a
green dot (Grp Ref) on the plan view. This reference point can be positioned anywhere, but a good practice is to
position it aligned with the weld center line and the probe/wedge center.

The focalization point (Focus Pt) represents the highest concentration of energy for each focal law in yellow Xs.

The scan axis is shown by a grey arrow.
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3.1.4 A-Scan

The A-scan view is probably the most important ultrasound view. For most cases, it is the source of all other views
such as B/D-scan, C-scan, and S-scan. The Cartesian Extractor cursor and Gates are available for this view.

A-scan view with the Cartesian Extractor cursor and two Gates

In phased array, the slider at the bottom allows you to navigate through focal laws (FL) one by one.

3.1.5 B/D-Scan

The B-scan is a view generated from the extractor angle of the S-scan or L-scan. If the extractor angle is changed, a
different B-scan will be created. Depending on your probe displacement, the B-scan may be considered as a D-scan.
In an encoded inspection, there will be no confusion between the B-scan and D-scan since the system knows the
direction of the probe.

Cursors available for this view are Cartesian Extractor, Cartesian, and Freehand.
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B-scan with the Cartesian Extractor cursor and one Cartesian cursor

The first slider at the bottom of the view allows you to position the Cartesian Extractor cursor along the scan axis.

The second slider allows you to navigate through focal laws (FL) one by one.

3.1.6 C-Scan

The C-scan is a view generated from a 0 degree linear scan. It can be described as a two-dimensional graphical
representation displaying the gate information obtained relating to signal features in a top, plan view of the part
under test. The specificity of the C-scan is that gates are used to extract information from the A-scan (for example
the amplitude of a specific echo).

A variety of information from gates may be displayed for different evaluation methods:

Signal amplitude

Depth (calibrated from the time base using material velocity)

Depth in a gate relative to the depth in another gate (thickness of material, depth of bottom surface relative to
top surface)

Signal amplitude in a gate relative to the signal amplitude in another gate (comparison of echo amplitude)

Cursors available for this view are Cartesian Extractor, Cartesian, and Freehand.
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C-scan with the Cartesian Extractor cursor and one Cartesian cursor

3.1.7 S-Scan

The S-scan view is a powerful tool available when using phased array probes. More generally, it is the accumulation
of color-coded A-scan lines or “pie” sections, placed side-by-side since they represent A-scans acquired at
different consecutive angles. Cartesian Extractor, Angular, Cartesian, Freehand, and Extractor Box cursors are
available for this view.

The S-scan is also called azimuthal or sectorial.

S-scan with an Angular cursor (indicated by a green arrow), the Cartesian Extractor cursor and
one Cartesian cursor

The information displayed at the top right corner of the view (Vel, WDly, Sen, and TCG) indicates, in green, what
was included in the calibration before the inspection: velocity, wedge delay, sensitivity, and time-corrected-gain
curve. However, if the calibration was done manually, the parameters included in the calibration will not be indicated.
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3.1.8 L-Scan

L-scan means linear scan. It presents, on screen, a parallelogram view at a specific angle. The L-scan view is
composed of multiple A-scans at the same transmitted angle, but from different exit points. The exit point variation is
due to the fact that a small group of active elements is moved along the array performing an electronic raster scan.
The L-scan is also know as an electronic scan (E-scan).

Cursors available for this view are: Cartesian Extractor, Cartesian, Angular, Freehand, and Extractor Box.

L-scan with one Cartesian cursor and the Cartesian Extractor cursor

The information displayed at the top right corner of the view (Vel, WDly, Sen, and TCG) indicates, in green, what
was included in the calibration before the inspection: velocity, wedge delay, sensitivity, and time-corrected-gain
curve. However, if the calibration was done manually, the parameters included in the calibration will not be indicated.
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3.1.9 TOFD

The TOFD view generally displays data using a gray-scale B-scan or D-scan. Cartesian Extractor, Cartesian,
Hyperbolic, and Freehand cursors are available for this view.

TOFD view with the Cartesian Extractor cursor and one Hyperbolic cursors

3.1.10 Top and End

Top and End views are extracted from L-scans and S-scans (refer to Extracting a View). They are essentially
projected views from a top or an end perspective of the part. Cursors available for these views are: Cartesian
Extractor, Cartesian, and Freehand.
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Top and End views extracted from the S-scan on the left
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At the bottom of these view there is an additional display feature, a level slider that acts as a gate threshold. It is
used to isolate indications and remove unwanted noises. For views that were extracted from the same cursor, the
sliders are linked.

  

Different display levels in Top and End views

3.2 Inspection

The Inspection tab in the Tree offers information about the inspection provided that this information has been set in
the inspection file.

Hardware settings cannot be altered during analysis.

The Inspection tab

Under Report Settings there is a list of parameters to add to the report. To add or remove a parameter, select or clear
the check box next to it. If some parameters have not been set in the inspection file they will not be available for the
report.
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3.3 Part

The Part tab in the Tree offers information about the part that has been inspected, its material properties (such as
ultrasound velocities), the weld description, and the calibration block used, provided that this information has been
set in the inspection file. Most of these parameters cannot be altered during analysis.

The Part tab

3.4 Probe

The Probe tab in the Tree offers information about the probe and its elements, provided that this information has
been set in the inspection file. These parameters cannot be altered during analysis.

For inspections made using more than one probe, click the left and right arrows at the top of the tab to move from
probe to probe.

The Probe tab
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3.5 Wedge

The Wedge tab in the Tree offers information about the wedge ,provided that this information has been set in the
inspection file. These parameters cannot be altered during analysis.

For each probe, a wedge is created; therefore, probe 1 is automatically linked with wedge 1, probe 2 with wedge 2,
etc.

For inspection made using more than one wedge, click the left and right arrows at the top of the tab to move from
wedge to wedge. 

When no wedge has been defined, the Wedge Type parameter will be defined as None.

The Wedge tab

3.6 Scan

The Scan tab in the Tree offers information about the scans, provided that this information has been set in the
inspection file. Some parameters on this tab can be changed during analysis.

For inspections made using more than one scan, click the left and right arrows at the top of the tab to move from
scan to scan. According to the type of scan, the list of parameters differs.
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The Scan tab

 The following describes the parameters that can be modified during the analysis.

Gain

Software Gain: Controls additional gain. This parameter can be changed to add or subtract gain in a *.utdata
file after acquisition.

Reference Amplitude: The desired reference amplitude used as default reference for AWS, TCG, and
Sensitivity Wizards. All measurements in decibels (dB) are referenced to this parameter.

Acquisition Area

The Travel Mode parameter allows the analyst to select the way the time-base is interpreted (half for pulse-echo
and full for pitch-catch or tandem) for the Angular cursor in the L-scan and S-scan, and the for the
measurement ruler in the A-scans.
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The Travel Mode list of parameters

3.7 Geometry

The Geometry tab in the Tree offers information about the relative position of each probe/wedge on the part and the
encoding area, provided that this information has been set in the inspection file. These parameters cannot be altered
during analysis. All probes appear in the list; click the arrow on the left of a probe to expand its list of geometry
parameters.

The Geometry tab
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3.8 Encoder

The Encoder tab in the Tree offers information about the encoder itself and the encoding setup, provided that this
information has been set in the inspection file. Under Statistics, you find the data file size and the encoding speed.
These parameters cannot be altered during analysis.

The Encoder parameter
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3.9 Measurements

The Measurements tab in the Tree provides all measurement information for all cursors in all views of all the sheets.

The Measurement tab

To make a selection of measurements, click and drag the ones of interest in the Measurements view (refer to
Measurement). Measurements are related to cursors and gates, letters and numbers identify them. In our example,
G2 refers to Gate number 2, H1 to the Hyperbolic cursor number 1, and H2 to the Hyperbolic cursor number 2.

The other possibilities are A for Angular, C for Cartesian, and E for Extractor Cartesian. The numbers assigned to the
cursors and gates increases each time a new one is added in a view or sheet. Therefore, if you have five sheets with
an A-scan in all of them and two Gates per A-scan, you will have gate numbers ranging from 1 through 10. If you
add a third gate in the A-scan of the any sheet, its number will be 11; that is for layouts for a same data file. If you
are working with more than one data file, the cursor and gate number will restart at 1 for each file layout.
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The following table presents the measurements information for cursors and gates.

ID Cursor Type

A Angular

C Cartesian

E Extractor Cartesian

G Gate

H Hyperbolic

I IFT Gate (interface)

ID Cursor Type

Peak amplitude

Leading flank amplitude

Start Start position of a gate

Stop Stop position of a gate

ID Measurement Type

%FSH Amplitude in percent

%REF Amplitude referenced to the
reference gain, or to the
curve (DAC or DGS)

Depth

 

True depth
(considering half-skip)

Sound path (from exit point)

Surface distance (from
wedge reference)

AWS

A, B, C, D

Indication rating (d), as per
AWS, using reference gain
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4 Analyzing Inspection Data

Inspection results analysis starts by opening a data file (*.utdata). UTStudio offers a wide range of tools to help the
analyst reach a decision in flaw evaluation. This chapter presents the UTStudio tools and how to use them.

4.1 Customizing Layouts

The layout is the way you set your view panes in a sheet. Views can be moved around, removed, and added. In a
data file, you have a wide selection of default layouts to choose from: 

The Acquisition Layout is the one used by the operator at the time of inspection. It is recorded with the data.

The Standard Layouts have been prepared by Sonatest.

The User Layouts are the ones that have been created and saved by analysts. These layouts are available no
matter what files you are working with (*.utdata and *.utcfg), if the scan type is compatible. Unlike the other
layouts, these can be added, renamed or deleted. 

On the Views tab of the Tree, click a layout and drag and drop it on the sheet.

Dragging a layout in a sheet

Moving the mouse cursor over a layout displays a small representation of the layout. In this case, an S-can and an
A-scan.

The sheet now contains the layout with the inspection data.
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The PA-A layout

4.1.1 Adding and Removing Views

Any type of view can be added to a layout as long as it is compatible with the scan.

To add a view:

1. In the sheet, select a view to split in half.

2. On the Layout menu click either Add Horizontal Splitter or Add Vertical Splitter.

Splitting a view to add an empty view pane

3. In the Tree, click the Views tab, select a layout and drag and drop it in the new empty view. In this example a
TOFD view.
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Adding a TOFD view

The TOFD data is displayed in the pane.

The TOFD view in the new pane

To remove a view:

1. In the sheet, select the view to remove.
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2. On the Layout menu, click Delete Area.

Deleting a view

Only the data is removed, the view pane remains. To remove it entirely repeat step 2.

Tip: To delete the view entirely with the pane, click  the X at the top right corner of the view twice.
The first click  deletes the data, the second one deletes the pane.

4.1.2 Swapping Views

You can change the order of the views in the sheet for any view.

To swap views:

Click the title bar of the view you want to move and drag and drop it to the view you want swap it with.

   

Swapping the A-scan and the S-scan
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4.1.3 Rotating a View

All views can be rotated (except for the 3D plan view). The rotation tool differs according to the type of view you are
working on.

To rotate a view:

1. In the sheet, select a view to rotate.
2. On the View menu, point to Rotate and click either Horizontal Left, Horizontal Right, Vertical Top, or Vertical

Bottom.

The View menu

The view is automatically rotated.

  

The original A-scan on the left and the rotated one on the right
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To rotate a 3D view:

1. Click in the view and drag the cursor to move the view.

  

Original 3D on the left and rotated on the right

Note: The plan (top view) cannot be rotated (lower left corner in the figure above)

4.1.4 Using the Zoom

A zoom function is available for the following views: B/D-scan, Top, End, TOFD, and all 3D views. The fastest way
to zoom in and out all these views is to click the view and use the mouse wheel.

There are two other ways to zoom views, except for the 3D views which only accept the mouse wheel action.

Zoom tools

1 From the toolbar

2 From the scroll/zoom cursor at the bottom of the views
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Note: For views that have a scroll/zoom cursor (number 2 in the figure), the zoom and scroll can
be modified on the View Properties tab of the Properties window (refer to Changing View and
Cursor Properties).

The Zoom value in the Properties window

Tip: The content of a view can be moved (panned) inside its pane by holding the Ctrl key of the
keyboard, and click ing and dragging the view.

4.1.5 Using Color Palettes

Many color palettes are available to characterize signal amplitude in any color-coded view. The default palettes are
selected in the Preferences dialog box, refer to User Preferences for more information. The choice of palettes is
found in the Properties window, on the View Properties tab. To display the Properties window, click the View
menu and select Properties.

The View menu
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Next to View Palette, click the value to open the palette list.

The Properties window

The following table presents the choice of palettes.

Palette
name

Regular Inverted

3-level
Threshold

ABF
Amplitude

Aeronautic

Cubic Law

Fire Ice

Grayscale

Rainbow

Spectrum

TOFD

Thermal

Inverted palettes are very useful when working with depth-type views.

All palettes can be shrunk and moved along the palette bar to isolate indications and remove unwanted noises.

In the following figure, we are displaying the same scan frame, but with a smaller palette range.
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The palette over the full range (left) The palette over a shrunken range (right)

4.1.6 Extracting a View

The standard layouts offer many view options; however, you can add more views by extracting them from existing
ones. You can get A-scans, B-scans, Top, and End views from an S-scan or an L-scan .

You can also get a C-scan from an A-scan; however that A-scan must have been extracted from an L-scan.

Extracted views are opened either in a new view pane, which you can create by splitting an existing view, or in an
existing view which will be deleted and replaced with the new one.

You can extract a view from a cursor position or from a new cursor. If you want to use an existing cursor to extract a
view, select the cursor first and then make a right-click on that cursor to open the contextual menu from which you
will choose the view type desired. If you want to use a new cursor, make a right-click anywhere in the view to open
the contextual menu from which you will choose the view type desired. A new cursor will be created in the view
used for extraction. For example, in an S-scan, if you extract a Top view, a Rectangle Box cursor appears in the S-
scan; if you extract an A-scan, a dotted angular cursor appears.

Note: The extracted view can replace an existing view or be displayed in an empty one. If you do
not want to lose any views, prepare an empty view area before extracting a view (refer to Adding
and Removing Views).

To extract a view:

1. Click in the view from which you want to extract a new view.
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2. On the contextual menu, point to either Extract From new cursor or Extract From current cursor and, in the list,
select the view type you want to extract.

The mouse cursor takes the shape of the selected view icon.

The list of views you can extract from a new cursor

3. Click in the destination view to display the new view.

The extractor (the cursor from which the view was extracted) will now be the master of the new view. This means
that moving the extractor cursor will change the slave view.

The A-scan was extracted from the L-scan and the merged C-scan (bottom view) was extracted
from the A-scan

Note: The A-scan gate positions appear on the extraction cursor.
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The location of the two gates

4.1.7 Adding Sheets

You can keep different layouts on separate sheets. There are three ways to add a new sheet: from the Layout menu,
from the contextual menu, and by clicking the green plus sign at the top right of the view pane display.

Adding a sheet

The sheet can be renamed by clicking the Rename this sheet command on the menus. To save this new layout, click
the Save sheet command. The layout then becomes available in the User Layouts list in the Tree.
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4.2 Using Cursors and Gates

Many cursors can be used in views. According to the type of view you have selected, different cursors will be
available.

The following table presents the gate and cursors.

Type Description Drawing

Cartesian
Extractor

The Cartesian Extractor is a default cursor that is linked in all extracted
views to allow the you to visualize any frame in a given view.

Cartesian

The Cartesian cursor is used to make surface distance and depth
measurements in L-scans, S-scans and A-scans. It is also called the
cross-hair cursor.

Angular

The Angular cursor is used to make sound path measurements in L-
scans and S-scans.

Gate
The Gates are used to make flank and peak measurements in A-scans.
When the gate is triggered by an echo, the peak amplitude level is
displayed.

Freehand

The Freehand cursor allows you to make a length measurement of any
indication or a distance measurement between indications, horizontally,
vertically, or at an angle.

It can also be used to mark and area of the part that cannot be created
with the part geometry parameters. For example, a part could present a
cavity destined to accommodate another part. The cavity could then be
marked on the scan so that this section would easily be ignored during
analysis.

Hyperbolic

The Hyperbolic cursor is used to measure surface distance and depth in
a TOFD view.

Extractor Box

The Extractor Box is used to determine the area for the extraction of the
Top and End views from L-scans and S-scans.
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4.2.1 Adding and Deleting Cursors or Gates

The list of available cursors is accessed through a contextual menu linked to the selected data view.

To add a cursor or a gate:

1. Make a right-click in the view for which you want to add a cursor.

2. In the contextual menu, point to Add Cursor and select a cursor from the list.

List of cursors from the contextual menu

To delete a cursor or a gate:

1. In a view, select the cursor you want to delete.

2. Make a right-click and, in the contextual menu, click Delete Cursor.

OR

Press the delete key on the computer keyboard.

Note: You cannot delete a cursor from which a view is extracted from. If you want to delete a
cursor that was used for an extraction, you must first close the extracted view (refer to Extracting
a View for more information).

Unable to delete cursor message

4.2.2 Linking Cursors

Two cursors can be linked together in two different views so that moving one cursor in one view will update the
linked cursor in the other view. You can also link a cursor in a view with another cursor in more than one view;
however, too many links will make it difficult to move the cursors.

You can only link cursors in views that come from the same data file.

You can link two Cartesian cursors to locate an indication from a view in another one. For example, linking the
Cartesian cursor in the S-scan with the one in the A-scan will link the the surface distance and depth measurements
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in the S-scan with the sound path measurement in the A-scan; linking them in an A-scan and a B-scan will link the
sound path measurements.

You can link an angular cursor in an S-scan with an A-scan, making the angular cursor the new extractor for the
A-scan.

You can link a gate in an A-scan with the Extractor Box in an L-scan or an S-scan. That gate then determines the
amplitude threshold used in the Top and End views that were extracted from the L-scan or S-scan. What happens
then is that the Top and End views will reject every indications that have an amplitude lower than that of the A-scan
gate.

   

Low amplitude threshold (left) and high amplitude threshold (right)

To link cursors:

1. In a view, click the cursor you want to link to another.

2. Make a right-click on the selected cursor and, on the contextual menu, click Link to.

The cursor contextual menu

The mouse cursor changes to a chain link symbol.

3. In the other pane, click the cursor you want to link to the first one.

To unlink cursors:

Make a right-click on one of the linked cursors and, on the contextual menu, click Unlink.



40Analyzing Inspection Data

Copyright © 2013

4.2.3 Making Measurements with Gates

Gates in the A-scan provide the usual functions from standard flaw detectors; they are positioned at a certain screen
height (amplitude) and cover a certain range (start and stop point on the sound path ruler).

The trigger can be set to determine which part of the signal is used for the depth measurement: the leading flank or
the peak. The leading flank measurement of a signal is often more accurate than the peak. All gates in a view can be
set with different triggers; they work independently. This setting is in the Properties window (View> Properties),
on the Cursor Properties tab, under Measures.

The triggered location is identified in the view by a small lozenge.

Leading flank (left) and peak (right)

Gates can also be used to isolate depth or amplitude data in a C-scan extracted from the A-scan (refer to Extracting a
View).

The amplitude or depth data displayed in the C-scan can ignore all signals from the 0 position to a signal in a gate or
subtract all signals in a gate (which becomes the reference) from another gate (which becomes the data source gate).

To isolate data from gates:

1. In the A-scan, set gate 1 on the desired signal.
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Absolute/Interface as reference

2. Click the C-scan view and, in the Properties window, under Data Extraction, select Absolute/Interface as the
Reference Gate.

3. Select G1 as the Data Gate.

The depth of the signal in gate 1 in reference to the absolute interface (part surface) is now displayed in the
C-Scan.

OR

In the A-scan, set gate 1 on the first peak and gate 2 on the second one.
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Gate 1 as reference

4. Click the C-scan view and, in the Properties window, under Data Extraction, select G1 as the Reference Gate.
5. Select G2 as the Data Gate.

The signal in gate 1 is subtracted from the signal in gate 2.

This example has been done using the amplitude mode. You can switch to the depth mode by changing the Depth/
Amplitude parameter. This changes the color coding of the palette; instead of showing higher amplitudes with a
stronger color, deeper signals will be shown with the stronger color.

4.2.4 Preparing TOFD Data for Analysis

Before marking indications with Hyperbolic cursors, UTStudio offers tools to define the lateral wave position and
align all A-scans on a common lateral wave (straightening).

Once you have your TOFD and A-scan views in the layout, click the Scan tab of the Tree.
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TOFD parameters in the Tree

Start by adjusting the position of the lateral wave and the position of the reference backwall. These offsets are used
to adjust the TOFD depth ruler.

The lateral wave indicator is represented by a white line in the A-scan. It must be set on the first positive echo of the
surface signal.

The backwall indicator is represented by a blue line in the A-scan. It must be set on the first negative echo of the
lateral wave backwall signal.

To adjust indicators of the lateral wave surface and backwall signals:

1. On the Scan tab of the Tree, use the arrows at the top of the tab to select the TOFD scan.
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TOFD parameters on the TOFD scan tab

2. Next to the TOFD section, click the arrow to expand the list.

3. Next to Ruler Lateral Wave Position, click the parameter and change it until the white line in the A-scan is in the
correct position.

The first positive echo of the surface signal

The backwall position (blue line in the A-scan) adjusts automatically.
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The first negative echo of the lateral wave backwall signal

The next parameter you might want to adjust is the straightening of the surface signal. In some cases this signal is
very granular due to the speed of inspection. 

Note: The position of the lateral wave and the position of the backwall must be adjusted first.

To straighten the surface signal:

1. In the Tree, on the Scan tab, under Straightening, select the Activate Straightening check box.

The Straightening Indicators parameter is automatically selected, a line appears on top of the surface signal, and
yellow straightening indicators appears at the top of the TOFD view.

2. Next to Lateral Wave Trigger Tolerance, click the parameter to open it, and increase or decrease the value in
order adjust the width of the green line to encompass the surface signal to straighten.
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Without straightening (left) and with straightening (right)

The next step would be to use the Hyperbolic cursors and the measurement view to evaluate indication signal in the
TOFD view.

To make measurements in the TOFD view:

1. Click the TOFD view and position the Hyperbolic cursor.

Measurements with Hyperbolic cursors

2. Add an empty view at the bottom of the TOFD view by using the Split function (refer to Adding and Removing
Views).
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3. In the Tree, click the Views tab and drag and drop the Measurement view in the new empty area.

4. In the Tree, click the Measurements tab and use the scroll bar to scroll through all measurements.

5. Select a measurement of interest, and drag and drop it in the measurement view.

6. Repeat step 5 for all other measurements you want to add in the view.

4.3 Software Gain

You can change the gain setting for each scan separately.

To change the software gain:

1. In the Tree, click the Scan tab.

Gain parameters in the Scan tab of the Tree

2. At the top of the tab, click the right or left arrow to select the desired scan.

3. Click the arrow at the left of the Gain category to expand the list.

4. Next to Software Gain, click the value to edit it.

Either use the arrows to change the value or, using the computer keyboard to type a value.

5. Click anywhere in the main window or press the Enter key to accept the change.
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4.4 Using the Part Overlay

Provided that the part drawing has been included in the inspection file, you can display its contour on L-scans, S-
scans, and A-scans.

To display the part overlay:

1. Select the view in which you want to display the overlay and, on the View menu, click Overlay.

S-scan with overlay (left) and part with weld in 3D (right)

To open the part contour in a view pane, in the Tree, on the Views tab, click Part and drag and drop it in the view.

You can change the overlay display by changing the number of half skips (View> Properties).
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The overlay for one skip

2. In the Properties window, in the View Properties tab, click the arrow on the left of the Overlays category to
expand the list.

3. Next to Half Skip Overlays, click the value to edit it.

Either use the arrows to change the value or use the computer keyboard to type a value.

4. Click anywhere in the main window or press Enter to accept the change.

4.5 Changing View and Cursor Properties

Many view and cursor parameters can be changed by the user; these changes are made in the Properties window. It
is a dockable window that can be floated anywhere on screen or, if you use two monitors, you can move it to the
second monitor.

The parameters will change according to the type of view and type of cursor selected.

The Properties window can be opened from the View menu, the toolbar, or the contextual menu. It opens on the
right side of the main window by default.
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Ways to open the Properties window

4.5.1 Changing the View Orientation

All views can be rotated (refer to Rotating a View). For all views except the 3D ones, the Properties window offers a
list of positions according to the selected view.

View orientations for A-scans, B/D-scans, C-scans, TOFD, Top, or End views

For 3D views, the rotation is done in the view by drag and drop.

4.5.2 Changing Palette Color, Position, and Amplitude

The color palette for most views is customizable, except for A-scans and 3D views, which are not color-coded.

B/D-scans, C-scans, S-scans, L-scans, Top, and End

For B/D-scans, C-scans, S-scans, L-scans, Top, and End views, the parameters that can be modified for the
amplitude color palette are the color gradient, the gradient position, and the low and high amplitude levels.
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Palette properties

The View Palette value opens a list of palettes to choose from (refer to Using Color Palettes for all the details).

The choice of palette position in the view includes: left, right, top, and bottom. You can hide the palette by
selecting None in the Palette Position list.

To change the amplitude level, click the value and either use the arrows to change the value or, using the
computer keyboard, type a value. Click anywhere in the main window or press the Enter key to accept the
change. In depth mode, the low and high thresholds are in mm or inch, meaning that the starting color will be at
the specified low depth and the end color will be at the specified high depth.

TOFD

For TOFD views, the color palette is always black and white.

4.5.3 Displaying Rulers and Grids

All views can show different rulers. Grids are available for all of them except for TOFD and 3D views.

Rulers and grids
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Different rulers are available according to the type of view selected. The following table presents the rulers available
to the analyst for his measurements.

Scan Type Ruler Type Ruler

A-scan Amplitude

Sound path

B-scan Scan axis

Sound path

C-scan
Top

Scan axis

Surface distance

D-scan Index axis

Sound path

L-scan
S-scan

Surface distance

Depth

End Scan axis

Depth

TOFD Scan axis

Depth (non-linear)

When an encoder is used, the reference point on the surface distance ruler (C-scan, L-scan, S-scan, and Top view) is

identified by a red dot . The values on the ruler are expressed either from the part
reference or the wedge reference.
To select the reference you want to use, on the Tree, click the Measurement tab and, at the top of the tab, open the
Encoded Axis Reference list and click one of the options.

Note: The example below shows the two rulers in a same layout for demonstration purposes only,
the reference selection will apply to all views from a data file, but not to all data files when work ing
with multiple files (refer to Analyzing Multiple Files).



53

Copyright © 2013

UTStudio - User Manual

Wedge reference (top) and part reference (bottom)
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4.5.4 Using Overlay Parameters

The overlay parameters include the display of the part overlay (refer to Using the Part Overlay) but also the display
of measurements for S-scans, L-scans and A-scans, and the envelope and TCG for A-scans.

The A-scan overlay parameters

4.5.5 Displaying Measurements in the View

Measurements from gates and cursors, in S-scans, L-scans and A-scans, can be displayed directly in the view.

Open the Properties window (View> Properties) and, on the View Properties tab, click the arrow next to Overlays
to expand the list.

Select the check box next to Show Measures in View.
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Measurements displayed at the top in the A-scan view

Measurements appearing in blue correspond to the gate selected in the view. Measurements include:

Symbol Description

Peak amplitude

Leading flank amplitude

Surface distance

Depth

Sound path
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4.5.6 Changing the Extracted View Display

Views can be extracted from the inspection data (refer to Extracting a View). These extracted views can be used to
display depth, and amplitude or beam path.

Extracted A-scans and B/D-scans show either depth or path (changes the ruler), and C-scans, Top, and End views
show either depth or amplitude (changes the actual data extraction).

Data Extraction parameter for an A-scan

4.5.7 Changing the 3D View Display

A lot of information can be added to the 3D views (refer to 3D views). The following example shows the various 3D
views available.

The View Properties tab for the overall 3D view (top left)

Overall view (top-left)

Displays a rotatable view of all active probes and scans with reference to the part datum.
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Part view (top-right)

Shows the thickness of the part and the weld parameters if a weld is defined.

Top/Plan view (bottom-left)

Displays a bird's-eye view of the setup and the encoding direction.

Probe view (bottom-right)

Shows the probe elements and the wedge. The wedge reference point is the red dot. For setups including more
that one probe, you can select a probe in the Probe list.

According to the selection you make in the Display Mode list, you will get a choice of probe or scan display for the
view.

   

For phased-array inspection you can view focal laws one by one for a given probe. To do so, you must select Beam
View as Display Mode, under Display set all parameters to Yes, under Beams set the Beams parameter to Yes, and
select a focal law number next to the Focal Law parameter.
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The Beams parameters allows you to view drawings of the beams, the near field, and the scan area.

Beams, near field, and scan area display

The 3D views Orientation parameter gives you a selection of camera positions; the default setting is Custom.

The list of orientation positions

4.5.8 Annotation Table

The Annotation table allows the user to display precise measurements in a table at the bottom of the main window.
The window is dockable and can be floated over the main window. To open the Annotation window, on the Edit

menu, click Annotations or, on the toolbar, click .



59

Copyright © 2013

UTStudio - User Manual

Opening the Annotation table

You can add an annotation to the table from the View menu, the contextual menu, or the toolbar.

Ways to add an annotation

Adding an annotation creates a box in the center of the selected view. That box can be moved around and resized to
contain the desired data. All measurements are displayed in the table for every annotation.
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Two annotations from an L-scan view

You can delete an annotation by clicking the annotation and clicking the Delete Annotation button on the toolbar or
by making a right-click on the annotation and selecting the Delete annotation command on the contextual menu. The
measurements appearing in the table are selected from the Annotations Columns dialog box; which is opened by
making a right-click on an annotation and clicking Annotations Columns on the contextual menu or by clicking the
Annotations Columns command on the Edit menu.

The Annotations Columns dialog box
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Lock

When selected, the annotation box is locked. It cannot be moved nor resized.

Name

The name of the annotation box. The number increases each time you add an annotation regardless of the view
or the sheet. Even if you delete an annotation the number keeps incrementing from the last annotation added.

View

The view in which the annotation box is located.

Defect Measurements

The values displayed in the Defect Measurements columns are defined in the Defect zone dialog box which is
opened by making a right-click in the Annotation table and clicking the Defect Zone command on the
contextual menu.

   

The Defect zone dialog box

Bonding: Threshold used for the Bonding column.

Amplitude defect zone: Thresholds used to measure defects in Amplitude views. The threshold can be in dB
(relative to the peak) or in absolute %FSH amplitude.

Thickness defect zone: Thresholds used to measure defects in Depth views.

The Defect zone dialog box can be docked beside the Annotations table for easy access.

The information of the Annotation table can be included in the inspection report by selecting the Annotation Info
check box in the Create Report dialog box (refer to Creating Reports).
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5 Analyzing Multiple Files

UTStudio offers the possibility to analyse many data files at the same time. In UTStudio, open each data file you
want to analyse (File> Open File); the files open different UTStudio sessions.
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6 Creating Reports

UTStudio allows you to create complete reports of the inspection and analysis. The elements to add in the report are
selected by clicking Create Report on the Report menu or selected on the Report section of the Inspection tab in
the Tree.

  

The Report menu and settings on the Inspection tab

According to the report type you select (Long, Short), some information will be included or left out. Some of the
information left out of the short report includes:

3D views Plan and Overall

Inspection information about probe quantity, scans quantity, voltage, acquisition frequency, etc.

Probe information such as type, manufacturer, model, etc.

Wedge information such as type, manufacturer, model, etc.

Information about the part, scans, geometry, and encoder

Other information may also be left out depending on the type of inspection.

The report shows the general information (operator name, inspection date, configuration file name, etc.) at the top
and a screen capture of the layout currently used in the selected sheet.

The report does not show all information of all layouts currently opened for analysis for a data file, only for the
selected layout. If many layouts are used, you must created a report for each of them separately.

The reports are generated in PDF format.

To generate a report:

1. Select the layout from which you want to generate a report.

2. On the Report menu, click Create Report.



64Creating Reports

Copyright © 2013

3. In the Create Report dialog box, Type the report information, select the report type and all the information you
want displayed in it.

The selection you make in this dialog box are automatically applied on the Inspection tab in the Tree and vice
versa.

The Create Report dialog box

4. Click the Create Report button.

5. In the Save report as dialog box, select a folder, type the report name, and click Save.



65

Copyright © 2013

UTStudio - User Manual

7 Exporting Thickness Tables as a CSV File

CSV stands for comma separated values. CSV files are often used as an easy way to exchange a large volume
database between programs.

The exporting function is used to extract a table of thickness measurements in an Excel worksheet. The table can be
expressed in percentages (amplitude) or in millimeters (raw data).

To export data as a CSV file:

1. On the Report menu, click Export to CSV.

The Report menu

2. In the utstudioG3 dialog box, select the type of data you want to export (Configuration details, Data).

The utstudioG3 dialog box

3. In the Data Format list select Amplitude (percentages) or Raw Data (millimeters).

In the case of multiple scans, you can export all scans or select one in particular in the Scan list.

By default, the number of frames and focal laws (FL) includes all of them but you can select a range of frames and
focal laws.



66Creating Configuration Files for an Instrument

Copyright © 2013

8 Creating Configuration Files for an Instrument

Configurations can be created directly from a test instrument, but you can also create them in UTStudio.
Configurations can be entirely or partially prepared in UTStudio and finished from the instrument at a later time.

There are three ways to create a new configuration:

Start from scratch (File> New File); a dialog box offers a choice of Sonatest instruments for which to prepare the
configuration.

Start with an existing configuration and save it under another name.

Start with a data file (*.utdata) and save it under another name (File> Save As) with the *.utcfg extension.

The File menu and the Save File dialog box

The inspection parameters on each tab of the Tree are now unlocked and can be modified (refer to Inspection
Parameters).

IMPORTANT: Remember to save the configuration as your work progresses by clicking the Save
File command on the File menu.

Probes and wedges can be loaded from a list already defined in UTStudio. Click the Load button and, in the Load file
dialog box, select a probe and click Open.
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Loading a probe

Note: Ideally, when you create a configuration file, it would be a good work  practice to make sure
that probe, wedge, scan, and encoder parameters are all set before loading it to the instrument in
order to keep the operator from guessing which parameters should be modified. Inspection, part,
and geometry parameters can be left to the operator’s judgment according to the conditions on
site.

While making changes in a configuration you may get an exclamation mark ( ) next to a parameter; this is to
indicate an inconsistency with related settings. The Summary view (Views tab of the Tree) will show all detailed
error messages.

Probes and Wedges

The maximum number of probes/wedges depends on the instrument.

If you are using an existing configuration, you can remove any unwanted probe by clicking the Delete button. If you
have more than one probe, at the top of the Probe tab, click the arrows to go through the probe list.

To add a probe:

1. On the Probe tab of the Tree, click the Add button.
2. In the Create new probe dialog box, click a probe name and click OK.
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The Create new probe dialog box

3. Change the default values of the probe parameters as necessary.

For each probe you add, a corresponding wedge is created; therefore, probe 1 is automatically linked with
wedge 1, probe 2 with wedge 2, etc.

4. Click the Wedge tab and use the arrows at the top of the tab to select the corresponding wedge.

New wedge corresponding to probe number 3
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5. In the Load file dialog box, select a wedge.

6. Change the default values of the wedge parameters as necessary.

Scans

You can prepare a series of scans to be performed concurrently, the maximum number of scans depends on the
instrument.

To add a scan:

1. In the Tree, click the Scan tab.

2. If you are using an existing configuration and you already have more than one scan, at the top of the tab, click
the arrows to go through the scan list.

Navigation arrows at the top of the Scan tab

You can remove undesired scans by clicking the Delete button.

3. Click the Add button.

4. In the Create new scan dialog box, click a scan type and click OK.
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The Create new scan dialog box

5. Change the default values of the scan parameters as necessary.

The list of probes and scans used in the configuration appears on the Views tab.

The list of probes and scans in the configuration

To see a 3D view of a probe or a scan, drag and drop it in a view pane.



71

Copyright © 2013

UTStudio - User Manual

Part and Geometry

When changing parameters on the Part and Geometry tabs of the Tree, it is very useful to open the overall and part
3D views. This allows you to see the changes to the scanning assembly as you are making them. To do so, click the 
Views tab and drag and drop the Overall and Part in view panes.

The Overall (top) and Part (bottom) views

Configuration summary

You can get a detailed summary of the configuration parameters in the Summary view. In the Tree, click the Views
tab, and drag and drop Summary in a view (create an empty view before if you do not want to replace an existing
one).

If there are elements of concern and/or errors in the configuration, colored lines will appear at the top of the
summary. Yellow messages indicate an element that you should consider and red messages indicate an error in the
configuration.

IMPORTANT: Errors must be resolved before trying to make acquisitions with the instrument
because any error will prevent the start of the acquisition.
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Consideration and error messages in the configuration Summary view
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9 Help and Support

For all parameters on each tab of the Tree and all parameters for each tab of the Properties window, you can get
information from the contextual help. Click a parameter and then, in the help menu, select Help.

The Help window is dockable and can be floated anywhere on screen or, if you use two monitors, can be floated in a
separate monitor.

Help docked at the top of the Tree (left) and floating over the layout (right)

Please contact your local distributor for additional support or training.

Visit our website or e-mail us at: 

www.sonatest.com

sales@sonatest.com

http://www.sonatest.com
mailto:sales@sonatest.com
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Contact Information

Country United Kingdom United States, TX

Name Sonatest Ltd Sonatest Inc

Department

Head office

Global sales management

Manufacturing

Flaw detector research and design

Sales

Product service

Support for the region

E-mail sales@sonatest.com sales@sonatestinc.com 

Telephone +44 (0)1908 316345 +1 (210) 697-0335

Fax +44 (0)1908 321323 +1 (210) 697-0767

Location
address

Dickens Road,
Old Wolverton,
Milton Keynes,
MK12 5QQ,
United Kingdom

12775 Cogburn,
San Antonio,
Texas, 
78249-2239,
USA

Website URL: http://www.sonatest.com 

mailto:sales@sonatest.com
mailto:sales@sonatestinc.com
http://www.sonatest.com
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